Tuesday, January 13, 2009

Parallels Clipboard Problem

I don't often copy and paste between Windows under Parallels and OS X. But it seems like every time I try, it doesn't work.

I've discovered one fix is to restart Windows. (Just suspending and resuming is not sufficient.)

I'm guessing the problem is that the Parallels Tools that run within Windows are getting messed up.

This is annoying because restarting Windows is not the speediest process.

This is on Parallels 4.0.3540 November 22, 2008 running Vista.

7 comments:

Matt H said...

Hey man, you're not alone. Lot's of people have problems with the clipboard feature in Parallels 4. I've even had Parallels clipboard problems crash OSX apps. Its unreliable, and difficult to reproduce reliably. Here's a couple threads on the Parallels site. They refuse to acknowledge...

I'm starting to think Parallels will probably just go out of business. They are not attentive to support, it seems.

"prl_cc.exe hogging processor"
http://forum.parallels.com/showthread.php?t=31621

"problem with prl_cc.exe at shutdown"
http://forum.parallels.com/showthread.php?t=88594

Anonymous said...

remove .NET 3.5 from windows and copy/paste will work again. at least that is my experience.

Anonymous said...

I had the same problem using the clipboard. I removed .NET 3.5 as suggested by the previous commenter and the clipboard problem went away.

rt said...

NET 3.5 fix seems to be working for me too. Thanks, folks.

Richard Hamilton said...

One more confirmation on Net 3.5. Running Parallels 5 , Snow Leopard and W7. Disabling Net 3.5, restarted Windows and clipboard now works.

Anonymous said...

I have done the same fix with uninstalling NET 3.5, but now items like Outlook and Word are failing from time to time. Am hoping that Parallels will come up with a fix for this and upgrade their software.

A boy can dream, can't he?

Wolfgang Fahl said...

Parallels Clipboard problems have been haunting me since day #1 I was using parallels. I event tried to bring back the software according to german law that products you buy should work as advertised and otherwise the vendor needs to care for a fix of exchange the product.
Bummer - nothing happend over more than two years. No reaction from support. No reaction on bulletin boards post. But lots of marketing buzz trying to annoy me. Fortunately I also have VMWare ...